台灣最大程式設計社群網站
線上人數
554
 
會員總數:245800
討論主題:189429
歡迎您免費加入會員
討論區列表 >> PHP >> 安裝CuteFlow出現的問題
[]  
[我要回覆]
1
回應主題 加入我的關注話題 檢舉此篇討論 將提問者加入個人黑名單
安裝CuteFlow出現的問題
價值 : 30 QP  點閱數:293 回應數:1
樓主

Robert
初學者
4 243
1530 102
發送站內信

Dear All
我想要找一個表單流程控制的軟體,發現CuteFlow似乎滿簡單的,我安裝後可以透過PhpMyAdmin進入Mysql中建立資料庫,但是執行http:\\localhost\CuteFlow進入安裝畫面卻出現no MYSQL Extension found,不知道是何原因?




搜尋相關Tags的文章: [ CuteFlow ] ,
本篇文章發表於2019-10-30 17:18
1樓
回應

maxmas
檢舉此回應
CuteFlow這個Open Source已經非常老舊了,大約是2012~2014發表的

你那個問題應該是CuteFlow 程式與你目前使用的PHP版本不兼容而引起的。
更具體地說,問題在於過時的MySQL擴展,該擴展自PHP 7.0起已刪除。

PHP官網說:
自PHP 5.5.0起不推薦使用此擴展,自PHP 7.0.0起已刪除該擴展。
相反, 應使用mysqli或 PDO_MySQL擴展名。另請參見MySQL API概述,以獲取選擇MySQL API時的更多幫助。
https://www.php.net/manual/en/intro.mysql.php

也就是說, 如果你的PHP是5.5以上, 將不支援CuteFlow連線MySql的方式,
你必須重新安裝你的PHP版本不要超過5.3, 或者你必須手動自己去修改CuteFlow的程式碼,
採用mysqli或PDO的方式連線MySQl
本篇文章回覆於2020-02-14 09:22
== 簽名檔 ==
--未登入的會員無法查看對方簽名檔--
   
1

回覆
如要回應,請先登入.