台灣最大程式設計社群網站
線上人數
1700
 
會員總數:245912
討論主題:189503
歡迎您免費加入會員
討論區列表 >> Linux / Unix >> 安裝php 和 curl
[]  
[我要回覆]
回應主題 加入我的關注話題 檢舉此篇討論 將提問者加入個人黑名單
安裝php 和 curl
價值 : 20 QP  點閱數:1204 回應數:0
樓主

jacobcan
初學者
1 55
692 75
發送站內信

請問各位要如何在redhat 裡安裝和執行php, curl.
我試了兩台機器
A: 有curl 沒php
有Errno 14, Error 404 錯誤
B:有php 沒curl
有dependence conflict.

我要如果解決這兩種錯誤? 謝謝
1:
在A裡用yum 裝php 跑下面error 改了 domain file /etc/resolv.conf 重啟network service 還是一樣
[root@A ~]# yum install php
Loaded plugins: security
http://public-yum.oracle.com/repo/EnterpriseLinux/EL5/6/base/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404: Not Found
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: el5_u6_base. Please verify its path and try again

2:
[root@ ~]# yum install curl
Installing:
curl i386 7.15.5-9.el5_6.3 ol5_u7_base 233 k
curl x86_64 7.15.5-9.el5_6.3 ol5_u7_base 230 k
Installing for dependencies:
krb5-libs i386 1.6.1-62.el5 ol5_u7_base 668 k
libidn i386 0.6.5-1.1 ol5_u7_base 194 k
openssl i686 0.9.8e-20.el5 ol5_u7_base 1.4 M

Transaction Summary
================================================================================
Install 5 Package(s)
Upgrade 0 Package(s)


Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test


Transaction Check Error:
package openssl-0.9.8e-26.el5_9.1.x86_64 (which is newer than openssl-0.9.8e-20.el5.i686) is already installed
package krb5-libs-1.6.1-70.el5.x86_64 (which is newer than krb5-libs-1.6.1-62.el5.i386) is already installed
file /etc/pki/tls/certs/Makefile from install of openssl-0.9.8e-20.el5.i686 conflicts with file from package openssl-0.9.8e-26.el5_9
.1.x86_64
file /etc/pki/tls/certs/ca-bundle.crt from install of openssl-0.9.8e-20.el5.i686 conflicts with file from package openssl-0.9.8e-26.
el5_9.1.x86_64
file /usr/share/man/man1/ca.1ssl.gz from install of openssl-0.9.8e-20.el5.i686 conflicts with file from package openssl-0.9.8e-26.el

搜尋相關Tags的文章: [ redhat php curl ] ,
本篇文章發表於2013-11-22 14:18
目前尚無任何回覆
   

回覆
如要回應,請先登入.